A Yocto/OpenEmbedded layer that provides in-vehicle infotainment (IVI) related functionality in an OpenEmbedded Linux system. This layer aggregates original IVI related software recipes for software components developed by Pelagicore. In addition, the layer contains appendments to other open source Yocto/OpenEmbedded layer recipes that are relevant for the aforementioned functionality

Git repository

https://github.com/Pelagicore/meta-bistro.git web repo

Last commit: 1 week, 6 days ago (master branch)

Maintainer

Recipe name Version Description
blueconnect 0.1+gita14c30d5a45a7864ed942386801bb070b6128dd0 Library for building bluetooth demos in Qt
buswatcher 1.0 buswatcher
colortest 1.0 A small test program to show a RGB test image on a screen.
common-api-c++-codegen 0.1+git81fe6698a95ba048ed2dbf1b557c884a97f939d6 common-api-c++-native
common-api-c++-dbus-codegen 3.1.5.fefb5e2f7e87ce01a5c53858fc0ba4f052cc4035 common-api-c++-native
common-api-cmdline 0.1+git74c695a0c70a7cf32a69b725baccaa4fd88846c4 common-api-cmdline
common-api-cmdline-codegen 0.1+git74c695a0c70a7cf32a69b725baccaa4fd88846c4 common-api-cmdline
common-api-dbus-integration 1.0
dbus-session 1.0 DBus user session
gst-instruments 0.2.1+gitX Profiling utilities for GStreamer 1.0 pipelines
gstreamer-testmedia 1.0 Helpers for installing different multimedia types
ivi-logging 0.1+git7ec74df57744189bdccb77a184beceefaf446ba3 ivi-logging
lms gitX Light Media Scanner
lms 0.4.5 Lightweight media scanner meant to be used in not-so-powerful devices, like embedded systems or old machines.
memsnoop 1.0
mp4v2 2.0.0 The MP4v2 library provides an API to create and modify mp4 files as defined by ISO-IEC:14496-1:2001 MPEG-4 Systems
nativesdk-packagegroup-common-api-host 1.0 Host packages for Common API code generation
packagegroup-bistro-utils 1.0 Packagegroups that add useful development tools to meta-bistro.
packagegroup-qt5-essentials 1.0 All Qt5 Essentials modules
peak-linux-driver-libs 8.6.0 PEAK CAN Bus Linux API
peak-linux-driver-modules 8.6.0 PEAK CAN Bus Driver for Linux
python-sip5 4.14.7 Runtime helper for sip-generated python wrapper libraries
qmldevinfo 1.0+git50a305aa42a8e542cac66b843fdbfaff08d58bf0
qtpim git
sip-native5 4.14.7 SIP is a C++/Python Wrapper Generator
softwarecontainer 1.0+git293d8f07c146fb3469868f79377a46b53771ab57 The SoftwareContainer framework
source-sans-pro 2.010R-ro-1.065R-it Adobe Source Sans Pro Fonts
swaplogger 1.0 Swaplogger
systemd-additional-units 1.0 Additional systemd units for user-sessions
systemd-genivi-targets 1.0 Systemd targets used by GENIVI Lifecycle components
Date/time Errors Warnings
Nov. 1, 2018, 12:10 a.m.
Oct. 30, 2018, 2:34 p.m.
Oct. 17, 2018, 3:06 p.m.