This layer provides Qt 4.x libraries as well as applications. Its primary use is for passing LSB tests as Qt4 is a requirement for LSB; however the libraries may also be used for any other purpose requiring Qt4.

Setup information Mailing list

Git repository

git://git.yoctoproject.org/meta-qt4 web repo

Last commit: 3 days, 14 hours ago (master branch)

Maintainers

Dependencies

The meta-qt4 layer depends upon:

Recipe name Version Description
core-image-lsb-qt4 1.0
fotowall 0.9 Creative photo display application
meta-toolchain-qt 1.0 Meta package for building a installable toolchain
meta-toolchain-qte 1.0 Meta package for building a installable toolchain
nativesdk-packagegroup-qt-toolchain-host 1.0 Host packages for Qt SDK
nativesdk-packagegroup-qte-toolchain-host 1.0 Host packages for Qt Embedded SDK
nativesdk-qt4-tools 4.8.7 SDK tools for Qt version 4.x
packagegroup-core-qt 1.0 Qt package groups
packagegroup-core-qt4e 1.0 Qt for Embedded Linux (Qt without X11)
packagegroup-qt-toolchain-target 1.0 Target packages for Qt SDK
packagegroup-qte-toolchain-target 1.0 Target packages for Qt Embedded SDK
python-pyqt 4.12 Python Qt4 Bindings
qmmp 0.8.6 Qt-based Multimedia Player
qt-demo-init 0.1 Init script for qtdemo
qt4-embedded 4.8.7 Cross-platform UI toolkit and application framework (framebuffer version)
qt4-graphics-system 1.0 Sets default Qt4 Graphics System to raster
qt4-native 4.8.7 Qt version 4 tools and support files for the build host
qt4-x11-free 4.8.7 Cross-platform UI toolkit and application framework (X11 version)
qt4e-demo-image 1.0 An image that will launch into the demo application for the embedded (not based on X11) version of Qt.
quicky 0.4 A simple note-taking application with Wiki-style syntax and behaviour
qwt 6.0.1 Qt Widget Extension for Technical Applications
Date/time Errors Warnings
Nov. 18, 2018, 9:56 p.m.