Name ruby-highline
Version 1.7.3 (327051c1c217df2880c3a53f31484f7e815e847f)
Summary Provides a robust system for requesting data from a user.
Description HighLine was designed to ease the tedious tasks of doing console input and output with low-level methods like gets() and puts(). HighLine provides a robust system for requesting data from a user, without needing to code all the error checking and validation rules and without needing to convert the typed Strings into what your program really needs. Just tell HighLine what you're after, and let it do all the work.
Section base
License GPL-2.0-only
Homepage
Recipe file recipes-devtools/ruby/ruby-highline_git.bb
Layer meta-webkit (langdale branch)
Inherits
  • ruby
Dependencies
  • ruby-native
  • virtual/i686-oe-linux-compilerlibs
  • virtual/i686-oe-linux-gcc
  • virtual/libc
PACKAGECONFIG options

Sources

git://github.com/JEG2/highline.git

Patches

None

Other branches

This recipe in other branches of meta-webkit:

Branch Recipe
master ruby-highline 1.7.3
nanbield (Yocto Project 4.3) ruby-highline 1.7.3
mickledore (Yocto Project 4.2) ruby-highline 1.7.3
langdale (Yocto Project 4.1) ruby-highline 1.7.3 (this recipe)
kirkstone (Yocto Project 4.0) ruby-highline 1.7.3
honister (Yocto Project 3.4) ruby-highline 1.7.3
hardknott (Yocto Project 3.3) ruby-highline 1.7.3
gatesgarth (Yocto Project 3.2) ruby-highline 1.7.3
dunfell (Yocto Project 3.1) ruby-highline 1.7.3