Name libtest-needs-perl
Version 0.002009
Summary Skip tests when modules not available
Description Skip test scripts if modules are not available. The requested modules will be loaded, and optionally have their versions checked. If the module is missing, the test script will be skipped. Modules that are found but fail to compile will exit with an error rather than skip.
Section libs
License Artistic-1.0 | GPL-1.0+
Homepage https://metacpan.org/release/Test-Needs
Recipe file recipes-devtools/perl/libtest-needs-perl_0.002009.bb
Layer openembedded-core (honister branch)
Inherits
  • cpan
  • cpan-base
  • perl-version
  • perlnative
  • ptest
  • ptest-perl
Dependencies
  • perl
  • perl-native
  • virtual/i686-oe-linux-compilerlibs
  • virtual/i686-oe-linux-gcc
  • virtual/libc
PACKAGECONFIG options

Sources

https://cpan.metacpan.org/authors/id/H/HA/HAARG/Test-Needs-0.002009.tar.gz

Patches

None

Other branches

This recipe in other branches of openembedded-core:

Branch Recipe
master libtest-needs-perl 0.002010
scarthgap (Yocto Project 5.0) libtest-needs-perl 0.002010
nanbield (Yocto Project 4.3) libtest-needs-perl 0.002010
mickledore (Yocto Project 4.2) libtest-needs-perl 0.002010
langdale (Yocto Project 4.1) libtest-needs-perl 0.002009
kirkstone (Yocto Project 4.0) libtest-needs-perl 0.002009
honister (Yocto Project 3.4) libtest-needs-perl 0.002009 (this recipe)
hardknott (Yocto Project 3.3) libtest-needs-perl 0.002006
gatesgarth (Yocto Project 3.2) libtest-needs-perl 0.002006
dunfell (Yocto Project 3.1) libtest-needs-perl 0.002006
zeus (Yocto Project 3.0) libtest-needs-perl 0.002006
warrior (Yocto Project 2.7) libtest-needs-perl 0.002005
thud (Yocto Project 2.6) libtest-needs-perl 0.002005
sumo (Yocto Project 2.5) libtest-needs-perl 0.002005